Skill Scanner

Seventy Was

Provider
Joined
Jan 10, 2011
Posts
192
Society
WildD3amons
Avatar Name
Seventy 70 Was
Hi, any ideas as to how to fix this?

Data!
Nothing found!
Clipboard error: cannot open system clipboard
 

NevadaJake

Stalker
Joined
Nov 14, 2007
Posts
1,724
Location
Reno, Nevada USA
Society
Freelancer
Avatar Name
Drake Slade Corbett
Hi, any ideas as to how to fix this?

Data!
Nothing found!
Clipboard error: cannot open system clipboard
This is what I did:

  1. Switch Entropia Universe to Windowed Mode (Res - 1366 x 768 - only for Skill Capture, switch back afterwards)
  2. Use ALT+Print Screen for each skill shot.
 

Seventy Was

Provider
Joined
Jan 10, 2011
Posts
192
Society
WildD3amons
Avatar Name
Seventy 70 Was
This is what I did:

  1. Switch Entropia Universe to Windowed Mode (Res - 1366 x 768 - only for Skill Capture, switch back afterwards)
  2. Use ALT+Print Screen for each skill shot.
Unfortunately I still am not able to use that,

Data!
Nothing found!

I guess pressing Alt stops saving to disk
 

Colbey Kal

Dominant
Joined
Aug 5, 2009
Posts
401
Society
NBK Otium
Avatar Name
Colbey Colbey Kal
Hi, any ideas as to how to fix this?

Data!
Nothing found!
Clipboard error: cannot open system clipboard
Same issue.

Running Windows 10 Home.
Running as Administrator did not correct the issue
 

atomicstorm

Marauder
Joined
Aug 21, 2013
Posts
7,355
Location
Tennessee, USA
Society
Entropialoot.com
Avatar Name
MeLoveYou LongTime FiveDolla
Hi, any ideas as to how to fix this?

Data!
Nothing found!
Clipboard error: cannot open system clipboard
Usually when this happens, I just print screen again and it goes away. Also make sure your PC is displaying at 100% DPI. Using 150% or more will ruin any OCR.
 

Seventy Was

Provider
Joined
Jan 10, 2011
Posts
192
Society
WildD3amons
Avatar Name
Seventy 70 Was
I have tried it a various resolutions, full screen and windowed. I think the key is the part saying it cannot access the clipboard. The very first time I tried, it brought back the stats without issue. Since then the clipboard message shows. This has also affected LBML not being able to read the deeds. Probably some new W10 security thing, but I do not know how to resolve it.
 

jdegre

Elite
Joined
Dec 24, 2005
Posts
2,957
Location
Madrid, Spain
Society
Survival Program
Avatar Name
Jesus jdegre de Gregorio
Sorry for not being of much help lately.

It's around 1 month or so that I cannot access EU due to technical issues that I'm trying to solve with EU support, but they seem to ignore my messages (the replied almost instantly when I opened the support case, 30 days ago, and they have never answered any of my further messges).

So, all the issues with the scanner, that I'd normally test myself in-game, I cannot do it at the moment.
 

jdegre

Elite
Joined
Dec 24, 2005
Posts
2,957
Location
Madrid, Spain
Society
Survival Program
Avatar Name
Jesus jdegre de Gregorio
Today, I got access again to EU.
I have tested the Scanner with EU, and everything worked fine.

For what is worth, this is the recommended setup:
- Have Java 8 properly installed in your machine
- Start EU and then the Skill Scanner in that order (not the other way around)
- When you are about to scan your skills, switch EU to window mode (in full-screen mode you screenshots will not be sent to windows clipboard; that's a windows "feature")
- Make sure your EU skills panel is in "foreground" and "focused" (note that if you click other items in the EU desktop, the skills panel dims out, and the scanner will not work)
- Make sure your EU skills panel is fully visible (specially all corners, since that's how the Scanner detects where is the skills panel)
- Have anti-aliasing not active in the graphics options
- Have gamma and brightness in default mode (if the scan fails, move it a bit to the darker side, not to the brighter side)

If everything fails, feel free to contact me and ideally have ready to send me screenshots in PNG format, so I can try to reproduce the errors in my PC.
 

Seventy Was

Provider
Joined
Jan 10, 2011
Posts
192
Society
WildD3amons
Avatar Name
Seventy 70 Was
At the suggestion of jdegre I changed the screen scaling to 100% at it works great! :yay:

I had not realised when I installed a new graphics card, that it scaled the screen @125%.
 

Bolivar

Old Alpha
Joined
Feb 10, 2010
Posts
994
Location
Netherlands
Society
Natural Born Killers
Avatar Name
Bolivar diGriz
I got it to work also, restarted Windows, and then followed the instructions.

I do need to press print-screen a couple of times sometimes for it to work though. But max 4 tries, so just fine :)
 

NevadaJake

Stalker
Joined
Nov 14, 2007
Posts
1,724
Location
Reno, Nevada USA
Society
Freelancer
Avatar Name
Drake Slade Corbett
@jdegre Could you consider making the signature feature compatible with the new forums? So many of us use this feature in our signature but it is no longer compatible for the following reason:

The problem is that the image is not static, but rather generated dynamically on the jdegre website.
PCF now uses an image proxy caching feature for all external images.
This has been tested with a "normal" external image in a signature and it worked.
Will investigate further, but it might not be possible to use images from jdegre's site if they are dynamically generated, unfortunately.


I don't know exactly how this could be resolved, but there must be a way. I am currently uploading my jdegre.net signature image to imgur.com and using that as my signature. But I would really prefer not to have to do that.

Thank you for this amazing service! It makes Entropia Universe much more fun.
:beerchug:
 

jdegre

Elite
Joined
Dec 24, 2005
Posts
2,957
Location
Madrid, Spain
Society
Survival Program
Avatar Name
Jesus jdegre de Gregorio
The problem is that the image is not static, but rather generated dynamically on the jdegre website.
PCF now uses an image proxy caching feature for all external images.
This has been tested with a "normal" external image in a signature and it worked.
Will investigate further, but it might not be possible to use images from jdegre's site if they are dynamically generated, unfortunately.
hi mate,
the signature images are generated in the "jdegre" site when you upload a new set of skill values. once it is generated, the image is a normal PNG image file, exactly the same as any other static image on the web. so, it's not that the images are dynamically generated upon request of the PNG image file, or anything like that.

i got a private message from another forum user indicating that the problem might be that the URLs in the "jdegre" site are hosted as plain "http" (as opposed to "https" URLs). this might indeed be the reason for the signatures not showing up in the new forum software.

if that is so, unfortunately at the moment it is not possible to offer "https" URLs for the signature files. not sure if the forum software might be configured to offer raw "http" support for external images; it not, then we are out of luck.

i may try to investigate another alternative, but so far, the only way forward (if the forum software cannot be tweaked to support http) is to host the images on the gallery, as you did.
 

jdegre

Elite
Joined
Dec 24, 2005
Posts
2,957
Location
Madrid, Spain
Society
Survival Program
Avatar Name
Jesus jdegre de Gregorio
the signature images are generated in the "jdegre" site when you upload a new set of skill values. once it is generated, the image is a normal PNG image file, exactly the same as any other static image on the web. so, it's not that the images are dynamically generated upon request of the PNG image file, or anything like that.
after some more investigation, I think that the issue might be much harder than I initially thought.

the main issue is that, apparently, the forum software takes a snapshot of the external image only at the moment when you crate your signature. then it stores such snapshot locally and it uses that image from now on, to display the signature in forum threads.

so, when i said before that the signature images are not "dynamic", what i meant is that they are not generated "on the fly" when the image is requested by the browser; in that sense, they are totally static image files, hosted in an external site (jdegre.net).

however, given how the forum software works, the image is only read by PCF once: at the moment of creating the profile signature.

if that is the only available working mode for the new PCF software, then there is nothing I can do from my side to fix that. it's simply that the forum software does not support the concept of hotlinking to external image files, and it only uses the image content once, when the signature is created.


EDIT:
I'm unfamiliar with Xenforo sofware, used by PCF, but doing a quick search on the web, I found that the forum can be configured to refresh the images it keeps in cache at certain intervals; I don't know how this is currently set in the forum but, if the forum would be configured to refresh cached images, say, every day, that could be an acceptable setting to refresh signature files, I guess.
 
Last edited:

girtsn

Marauder
Joined
Dec 7, 2005
Posts
7,460
Location
Belgium
Society
Holy Moly
Avatar Name
Girts Smilgs Niedra
In the end I went with the suggested workaround, uploaded the png in my own website which is on https, and linked to it - seems fine (also added in signature).
 

NevadaJake

Stalker
Joined
Nov 14, 2007
Posts
1,724
Location
Reno, Nevada USA
Society
Freelancer
Avatar Name
Drake Slade Corbett
I just save my image file from the Skill Scanner site and pop it onto Imgur. Ease the bandwidth usage and it works. It seems weird that Imgur works but not the Skill Scanner site directly:
:thumbup:
 

NevadaJake

Stalker
Joined
Nov 14, 2007
Posts
1,724
Location
Reno, Nevada USA
Society
Freelancer
Avatar Name
Drake Slade Corbett
Oh no! We all need to support jdegre. The skill scanner is down because the domain is suspended.

Skill Scanner is down :duh:
 

jdegre

Elite
Joined
Dec 24, 2005
Posts
2,957
Location
Madrid, Spain
Society
Survival Program
Avatar Name
Jesus jdegre de Gregorio
i have checked the domain itself, and it should be fine; at least the info from the domain registrar indicates no problems.
i suspect it might be due to an outage of my hosting provider (which is different than my domain registrar).
i'll keep an eye on this and see what i can do... sorry for the inconvenience :(
 

NevadaJake

Stalker
Joined
Nov 14, 2007
Posts
1,724
Location
Reno, Nevada USA
Society
Freelancer
Avatar Name
Drake Slade Corbett
I am so thankful for all that you do @jdegre . Skill Scanner makes tracking my progress fun.

Here is a screenshot of the error I get when launching the application (if it helps):

 

girtsn

Marauder
Joined
Dec 7, 2005
Posts
7,460
Location
Belgium
Society
Holy Moly
Avatar Name
Girts Smilgs Niedra
indeed guess its a similar issue as the java client is failing with, just a different url and browser behavior
When I open that link in the browser it forwards to this page:
 

jdegre

Elite
Joined
Dec 24, 2005
Posts
2,957
Location
Madrid, Spain
Society
Survival Program
Avatar Name
Jesus jdegre de Gregorio
yes, both the web page (Chipping Optimizer) and the Java app (Skill Scanner) depend on the same domain (jdegre.net) to work fine.

as commented before, the domain itself seems to be fine; so it's not for sale, or with unpaid bills or anything like that :)

i suspect from the hosting provider (iFastNet) because i tried to access the admin console and it won't let me enter, as if the site was down. still, redirecting the DNS lookups of my domain to a "suspended domain" page is a bit confusing tbh; in other cases, the "normal" behaviour when the site is down is either to timeout the request, or to respond with HTTP 500 Server Error, or similar...
 

NevadaJake

Stalker
Joined
Nov 14, 2007
Posts
1,724
Location
Reno, Nevada USA
Society
Freelancer
Avatar Name
Drake Slade Corbett
Thank you again for everything @jdegre!

I sure hope iFastNet didn't get hacked.
 

WoenK

Elite
Joined
Feb 26, 2008
Posts
3,943
Location
Munich
Society
Riverboat Gamblers
Avatar Name
Irdeta WoenK Hocren
i have checked the domain itself, and it should be fine; at least the info from the domain registrar indicates no problems.
i suspect it might be due to an outage of my hosting provider (which is different than my domain registrar).
i'll keep an eye on this and see what i can do... sorry for the inconvenience :(
It is not critical to scan every day and you are providing us with a really unique tool :D
And you have done it for so many years, so IMHO...enjoy the last days of summer, I think we all can live some days without the scanning and it will surely get fixed in time :D
 

jdegre

Elite
Joined
Dec 24, 2005
Posts
2,957
Location
Madrid, Spain
Society
Survival Program
Avatar Name
Jesus jdegre de Gregorio
it seems everything is back to normal now. as suspected, it was due to a temporary outage of the hosting provider.
 
Top